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Next Steps: Houdini Procedural Modeling

MOS5: Grass - Building and Rendering Curves

Ari Danesh SIDE EFFECTS
ari@sidefx.com SOFTWARE
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Goal of this Module

» Learn how to add attributes to a curve
» Remember that in Mantra you can render curves
» Once the attributes are created
» How do we make shaping tools for the grass blade
» Create a two sided shader for the grass
» Includes color information

» Includes Displacement information

SIDE EFFECTS
SOFTWARE
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A Quick Test

Do Curves Really Render? Are they Controllable?

SIDE EFFECTS
SOFTWARE
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The Setup

» Create New Scene

79 circle

» Drop Down a Circle
» Plane - ZX
» Type - NURBS

» Divisions - 10
» Place Camera in Scene
» Go to Render

» You get a nice surface render of the circle
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The Setup (cont.)

» Dive back into the circle

» Append and Ends SOP to the Circle
» Close U - Unroll

» Remember Unroll disconnects the first from last point

» Render

» A Curve I1s Rendered!
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The Setup (cont.)

O

» But can we control the Curve?

.ﬁ attribcreatel

» Append an Attribute Create
» name - width

» The render disappears

» Class - Point
» Value 0.01

» A Curve i1s Rendered!
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Can we shape the Curve?

» Change the Class to Vertex

» In the Value type the Expression
R ocrer _ » SVTX/(FNVTX - 1)

» We are dividing the vertex number by the total number
of vertices to give us a width ranging from O to 1

» This is how we will go about creating Grass

lue  $VTX/($NVTX-1)
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Setting Up the Testbed for Grass

Sub Title

SIDE EFFECTS
SOFTWARE




» Drop Down a Sky Light
» Drop Down a Grid
y Size 4x4
» Rename to "grass”
» Drop Down another Grid
» Size 4x4
» Rename to “"ground”

» Position a camera in the Scene

Basic Setup

I ground

Lights
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Basic Setup (cont.)

» Dive inside the Grass

» Drop down a Line
» Primitive Type - NURBS
» Divisions - ©
» Order - 4
» Append a Transform
» rot-x = 90

I'_'l copy __uaea_M_az_aim_and_up_az_up

» Append a Copy

» Template - Grid

» Primitives to Copy
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Adding the Attributes to Shape the Blade
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What do we want to control?

Blade Thickness (variable along length)
Blade Min Height

Blade Max Height

Blade Bend

Blade Twist

Blade Rotation

Blade Up Vector




attribpromotel Take List Parameter Spreadsheet + =
o o [T Add a few Attributes

. Jump Forward Alt+RightArrow
‘«L'( AttribPromote attribpromotel
Original Name pct
Original Class Vertex
New Class Point

Promotion Method Average

» Append a Attribute Create

» name - pct

» class - vertex

S, S RO,
Parameters: attribcreate_pct backbone

.. ODbj {‘ grass

53 AttribCreate attribcreate_pct_backbone g } Va.l ue - $VTX/($NVTX _1)

Group

Group Type Guess from Group

wumber of Atrbutes i » Append a Attribute Promote

¥ Name pct

Existing Name Use the better type, size and precision

» Original Name - pct

Class

Ty Guess from name Illl linel l.ll gridl o
| » Original Class - Vertex

Size 1

ot I Iléll xforml :
v » New Class - Point

Value  $VTX/($NVTX-

RN -or):

llll attribcreate_pct_backbone

a2 attribpromotel
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Define Attributes in VOPSOP

» Append a VOPSOP and Dive inside
» ImportAttribute - pct
» AddAttribute

» name - width

» type - float
» Give It a size for now - O.2

» Render

Tuesday, April 9, 13



|mportattr|b1 pct

attrib
a

npt

num

addattrib width

Define Attributes in VOPSOP (Cont.)

» Wire up the pct (backbone) to width
» Render
» Notice two things
» Variable Width
» All curves “"Oriented” toward camera

» First Let us shape the blades with a ramp
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Take List Parameter Spreadshe

~. obj » Ty grass ) &) vopsopl

* % Parameter input2

Name grass_scale

Label

Type
1 Float Default

Float Range

et

Shaping the Blades

In the VOPSOP drop down a Ramp Parameter VOP
) name - grass_shape
label - Grass Shape
» Type - Spline
» Append a Multiply (We want a global scale to the shape)
» Wire it up - ramp to multiply
» Promote Second Input

» name - grass_scale

Shape it into

label - Grass Scale

a blade of
» Go up and Shape blades grass

|mportattr|b1 pct rampl grass shape)

u attrib success u u input
n input_i... adata u
3 ptnum

grass ...
grass_...
grass_... fie
grass_... Ld
grass_...

multiply 1l

addattrlb width

u attrib  newad...

K& adata
u localvar

Tuesday, April 9, 13
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RENZARE -

II xforml

IIII scatterl

Normal Vector & Up Vector

» Append a Scatter SOP after the Grid SOP

» Notice the Grass Blades flat on the ground
» We can fix this by adding a Normal Vector
» Append a VOPSOP to the Grid SOP

» Dive inside - Wire Normal to Normal
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Normal Vector & Up Vector (cont.)

global0

s [ []] addattrib_up
- L iRE

ot e output » Drop down an Add Attribute to the VOPSOP

h... N

n°§<?1
n

» name - up

» Label UP

Take List Parameter Spreadsheet

rib_up ' .
%. obj } fg grass € vopsop2 : ; } Value _ O 1 O
%)

‘;: Add Attribute addattrib_up

)Lgt::::,t: u:ectorAttribute } Type MOd'fler - VeC'tor Da'ta

bata Vector o » Promote the adata

Type Modifier Vector Data

addattrib_up Take List Parameter Spreadsheet 4 ‘ } n am e = u p_ve Cto r

. obj ) fg grass &) vopsop?2

53 pdd Attribute addattrib_up D ( » Local Variable Name - Up Vector

Attribute  up_vector
Local Variable Name Up Vector

Data Vector 0

Type Modifier Vector Data
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Why Not Use a Card with Alpha?

Alpha slows down rendering

Shaping curves very efficient in Mantra

SIDE EFFECTS
SOFTWARE




Controlling Random Size

» Let us start with Size

N
—0 N
a0 ER
nnlt« 21-

a
st
n

i
um
Cd
ime

» Drop down a parameter
» name - seed
» Label - Seed
» Range - 0..100

» Add to Ptnum and bring into Random VOP

fit__height_to_min_max

» Output Random to a Fit Range
» Source Min, Max - O,1

» Promote Destination Min, Max
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Controlling Random Size (cont.)
» Import Attribute - pscale

» Drop down a Two Way Switch

» We need to make sure pscale is present

importattrib__pscale

» success of pscale to condition of switch e cueay
e —
e

» adata to input 1 of switch

» Drop down a constant - value 1

» Wire to input 2 of switch

» Drop down a Multiply

» Input 1 - output of two way

» Input 2 - output of Fit Height
» Drop down an Add Attribute

» Attribute Is pscale
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Controlling Random Direction

» Drop down a Switch (Do we want random or straight
orass)

» Promote the Switcher

} N ame _ rand O m_u p_d I reCtIO n harm u (up_direction) ‘ m{-hll!g rﬁ!g

n inputl

» Label - Random Up Direction

» Wire the Up Direction Vector to the First Input of Switch

» Append a Normalize to the Switch
» The Output of the Normalize wire to N of Global Output
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Controlling Random Direction (cont.)

» We took care of the straight grass condition. Now let us
do the rand direction grass

» Drop down an Add SOP
» Wire the PtNum and Seed Outputs to the Add

» Drop down a Constant - make some large value

» Wire to Add
» Wire the output of the Add to a Random VOP
» Fit the output to a negative to positive 1

» Drop down an Add

» ADD THE UP_DIRECTION AND THE FIT JUST
CREATED

» Wire the Add to input 2 of the Switch

Tuesday, April 9, 13
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Point Group

Number of Threads

Compiler

Evaluation Node Path

UP Vector

Minimum Grass He...
Maximum Grass
Up Direction

Seed

a.,.; VOP SOP vopsop__source_grass_attributes # E—‘JJ ‘/1‘\ @ , ,
n I
r | & &%
1 Per Processor F o
vce -q $VOP_INCLUDEPATH -o $VOP_OBJECTFILE - S o 18 0
” 2 '
Force Compile ¢ ’ /
i i
il - | 4
- v o
TS A S r B
] ¥
0.1 =
0 i
¥ Random UP Direction /
- ’

Results of VOPSOP

» Random Orientation & Size

» and of course shape Is still working

5 ‘\

¥ ' ¢
pe i B

N\ N
i N\ \
e

r

P od
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Creating Orientation, Twist, and Bend

and putting it into an if statement

SIDE EFFECTS
SOFTWARE




» We will need the Up Vector
» In the Copy SOP go to the Attributes Tab
» Select - Use Template Point Attributes

» We do not want to bring along surface
normals - "N

» Now the Up Vector comes along for
the ride

Adding Orient

Take List Parameter Spreadsheet &

. 0obj ) [y agrass

1" Copy copyl

Source Group
Template Group
Copy Stamp Attribute

¥ Use Template Point Attributes

Set Mult
To Point  *,”v,”~Alpha, “N Alpha

To Primitive
To Vertex

¥ Copy Local Variables

Tuesday, April 9, 13



» Drop into the same VOPSOP as the grass shape tool
» Drop down a if_then-Block VOP

» We want the user to determine if the artist wants an
orient attribute

» Promote the condition of the if then Block

» name - use orient

Adding Orient (cont.)

=P - = oy
condition Take List Parameter Spreadsheet w

. 0obj ) Tg grass € vopsop shape_and_ori

* % Parameter condition

Name use orient
Label Use Orient
¥ Show Label

Type Toggle {int)

Toggle Default

» Label Use Orient

» Type - toggle (int)

W condition
u next

Tuesday, April 9, 13
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» Dive inside the if_then_Block
» Add Attribute
» Attribute - orient
» Local variable name - ATTRIBUTE
» Drop down a Constant VOP
» Type - Vector
» Value - 0,01
» Constant Name - _orient
» Drop Down a Transform Matrix
» Wire everything up

» Rotate y in the transform and see results

Adding Orient (cont.)

const1(0, 0, 1)

xform1 addattrib orient

Q attrib  new... &
0 adata

4 localv ar

condition Take List Parameter Spreadsheet 4

. obj » Ty grass } &) vopsop_shape_and_oris

* % Parameter condition

Name use orient

w condition
u next

Label Use Orient
¥ Show Label
Type Toggle (int)

Toggle Default

Tuesday, April 9, 13
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Twist & Orient - The Real Thing

nulll

5 gra... ultiply addattrib width
' _ gra... |

B adata _pct B
B next

» We want to setup all the Twist and
Orient Parameters outside the if
statement

» Need a parm for

—

G [

Sh3 = O

n 3 i-g r:'
on ¥ |

- 0 ~

ca g —

3 -

w e 1

-3 s

ramp2 (twist_ramp)

B input  twi...
b

» twist

3
|
H
Iz|
5|
=}
Hr
|

rotate grass amt (rotate_grasswmt)

_FEEEREE
) rotate s

random_twist enable (random_twist_enable)
[ =i g

random_twis... [l

WI ound_rando...

» seed value
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Twist & Orient - The Real Thing (cont

subinputl

_condition |l
_pct l
_twist_ramp B
rotate _gras...
“random_twi... B
seed |

“rand B

multiply twist by ramp

M inp... pro..
| mput2
B input2

fit _rotate to_unit_size 0-1
L]

B val shift l

M srcmin multiply reverse
M srcmax

M destmin _.ll

B destmax M inp... pro..

2| |nput2
B input2

addl

importattrib__ pid Ill
-III B
B sttrib suc.. H inzut3

M inp... ad.. .
= ptnum

randoml

MW pos rand B

mix_from_pos_to_neg_rot_amt

o []]]
M inp... blend B
M input2

B bias

fitl
o [
B val shift B
M sremin
B srcmax

B destmin
B destmax

add2

I REE
M inp... sum Bl
M input2
B input2

const__orient(0, 0, 1)

L

_orient [l

floattovec?2

M frall vec B
M fval2
B feal2

degtoradl

B deg rad

xforml

Bl pos xfo...
M trs

M xyz

M trans

B rot

M scale

W pivot

sinel
-III floattovecl
we® NN

B fvall vecH
M fval2

cosinel B fval3

Cos..

» Inside the If Statement - Overview

addattrib__

B attrib  ne..

B adata
B localvar

suboutputl

_condition

pct
_twist_ramp
rotate_gras..
random twn
sead
rand

ext

Tuesday, April 9, 13
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What Is Going On?

Two tracks - Calculate rotation and twist then add them together for final output
Generate a different random value based on seed and pid

Use that to mix the twist and rotate

Tuesday, April 9, 13



Bending the Grass

importattrib__ pct

B attrib suc... B
M inp... ad.. B
B ptnum

globall

PR
Pw B
v H
accel H
age B
Ite W
pstate l

id
ptnum [l
o- N |
NE
Npt
Time H
Frame [l
Timelnc B

ramp3 (be

nd ramp)

IS T

multiply _bend_amount

M inp... pro... B
ol input2

M input2

B inputd

floattovecl

B fvall vecB
B fval2
B fval2

addl

C ISNEE

W inp... sum B
B input2
B input2

outputl

sha... B

=00 <TI0
O -F- I

o
3
2
n

EEEE .
o

=0
=

Tuesday, April 9, 13
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Final User Interface

0" VOP SOP vopsop__curve_shaping_attribute Q

Point Group

Number of Threads 1 Per Processor

vee -q $VOP_INCLUDEPATH -o $VOP_OBJECTFILE

Compiler

Force Compile
Evaluation Node Path

Grass Shape

Point No. 4
Position 1
Value O
Interpolation Linear
0.005
¥ Use Orient Vector

Rotate Grass Amt 228.6

Twist Ramp

Point No. 3
Position 1
Value 1
Interpolation Catmull-Rom
Random Twist Enable
Seed O
Bend Amount 0.005

Bend Ramp

Point No.
Position
Value

Interpolation Catmull-Rom
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Grass Shader

Sub Title

SIDE EFFECTS
SOFTWARE




Goals of Shader

Start with the Leaf Shader
Blend between two shades of Green
Have a front side and back side to the shader
» Front side - darker green, more waxy (more specular)
Have a Spine (darker Green)
Create a Fold - Displacement from outside of blade to spline

Subsurface Shading - free with Grass shader




What We Will Do

SIDE EFFECTS
SOFTWARE

» We will add

attributes and logic

o O S S
Aau ) AHV A“v
c & S
Hh o= =89
') We
T eT g9
dg 8 2l
G 0N Sa
2090 O
tC% O O
oo B FE
A

the Leaf Shader

36
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sss_int (sss_int)

sss_int B
bound_sss... B

multiply2

I in..
|nput2
B input2

luminancel

lum B

Junmaddddduls

surface color

colorM ap.

colorM apfi...

colorM ap..

color apE...

scoo

tcoord

usePointAl...

colorMapl... colorManl...

1H-—a '_::. A‘

us..
ba... el... l
usePoth...
uzeColor...
baseColor...
colorMap...
mlorMapfl...
colorMap...
colorMapB...

B scoo

M tcoord

3 usePointAl...
flI colorMapl...

colorMapl...

opaé-clr (opac_clr)

opac_cir B
ound_op... B :
multiplyl

u[di't color

M us... co..
B ba... al.. l
B usePointC...
g useColor...
g baseColor...
8 colorMap.
co orM apfl...
colorMap...
colorM apE...
scoo
tcoord
usePointAl...
colorMapl...

globalP
00
PR

globalN

00!
NE

disp_color luminance

51 Hrgbh lum B

ba al... 2]
usePointC...
useColor...
baseColor...
colorMap .
colorM apti...
co orMap :
colorMapB...
scoo
tcoord
us=PointAl...
colorMapl...

JII-.JJJ‘- II

conserv ee...
fres _enable
fres_style
ior_in
ior_out

s35_ena
555 int
sss_clr
555_min
ss5_atten
sss_attenclr
sss_phase
sss_lenable
sss_linten...
535 lqueltty
sss_2enable
s35_pcmode
s35_pcname
s35_2inten...
553 2qualny
refl_lights
spec_model
spec_int
spec_min
spec_clr
spec_angle
spec_aniso
spec_anis..

opac_int
opac_ clr
more..

displacenml

disp_output

output_collect

B shaderl
B shader2
B shader2
B shaderd

properties

Look at the Leaf Shader

» Disable - Use Color map

» Dive Inside. Look at different
components of SHOP Network

Material Shader Builder leaf

Surface Displacement OpenGL
Diffuse Subsurface Reflect Opacity

Diffuse Intensity 0.5

Oren-Nayar Rough

¥ Use Point Color

¥ Use Color Map
Base Color Map mapleleafColor
Map Intensity
Color Map Wrap Repeat
Color Map Filter Catmull-Rom

Color Map Width

¥ Use Base Color

B o

Settings

rat

Tuesday, April 9, 13
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Adding Two Sided Shader

diff rough_front (diff_rough_front)

diff_rough_front [
bou l_]rff_ :]

diff rough_back (diff_rougfiback) twoway1

_III E-II!
bind orient( orlont' isfrontfacel diff_r 9' ba esukt

bot ddrH g prtl

D inpu2

» Bind the Orient Attribute

» Key to this operation is the isFrontFace Node

diff_int_front (diff_int_front)

I woway?z
diff_int_fronmt |4 two aY

i B Commus » Use a Two Way Switch to two switch between

& inputl

b input2

diff_int_back (diff_int_back)

o 1 — » roughness
bound #t it ... B I!I

"'ﬂ';rtl
[ft

spec_angle front(spec angla front) } dlffuse IntenSIty
E-III

glfﬂii
b d spec_an... [

» spec angle

spec_angle_back(spec_angle_back)

SIDE EFFECTS
SOFTWARE
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slagde Lolor

light_grass color(light_grass_color)

dark_grass_color(dark_grass_color)

dark_grass_color §

bov.m:l_dal’:_gr... v

bind__ pidf(pidf)  rintl random1 fit1
z EEE ENENENl CEEEi d N 1| 1
Dipt piE—— Dvel  rmE— Dpos  rend 3 Dva  sht D
— 1 et colormix1

vl
& destmin
#] dest

Adding Blade Color

» Use the pidf as a seed to randomize color

» Use the Fit to constrain color range (if you
want)

» Create a light color and dark color for mixing

» Use a Color Mix to blend based on random
value

SIDE EFFECTS
SOFTWARE
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Spine Color and Displacement - Part O1

smoothl

widthfold

O com... widt... D
u next

subtract range 0-1-0

dit I

L inputl
id input2 complement_range 1-0-1

& val com... 3

| | » We are going to use two smooth operation to
Co— smooth between light and dark. Then subtract

blad... &
blad ., |

o the two to get the actual spine

» We will use this gradient for both color and
displacement

SIDE EFFECTS
SOFTWARE
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Spine Color and Displacement - Part 02

Spline Color Part 2

parml(spine _color)
E-ﬁg
spine_color

bound_spine_color e

ramp color(spine_color_ramp)
multiply5

:.-EW

» We now use the Spine gradient created in Part
O1 as the input into a spline ramp

» We will then multiply it by a value to specity

how dark we want the spine

SIDE EFFECTS
SOFTWARE
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light_grass_color(light_grass_color)
_Ill

b dlgh‘tg I

dark_grass_color(dark_grass_color)

blnd __pidf (pidf) rintl randoml
ke II] -III I!!
pos ran

colormixl
I-III

. sssss dary
B bias

B adjust
B space

Spline Color Part 2

parml (spine_color)
E-III

spin
bou dp ..

input3 ’
ramp_color(spine_color_ramp)

multiplyS
EI-II!
G G

i
>l input2
B input2

colormix2
_III

ll sssss dary

B bias
adjust
space

Mixing the Colors

» Now we mix the spine color with the blade color to get the input into the base color of the surface color

SIDE EFFECTS
SOF TWARE
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» Take the luminance and add it to spine for displace along normals

"{7_7[" coIor

B useB... color

E base... alpha O

B usePointColor

K useColorMap
oL baseColorMap
@ colorMapW rap
e colorMapfilter
0 colorMapWidth

H colorMapBorder

E scoord

KB tcoord

B usePointalpha
&0 colorMapintensity

lun

2 rgb lum 2

Spline Part 01

smoothl

n min val D
EH max
O amoum

B rolloff

smooth2

& min val 3
B max

O amount

O rolloff

&0 useColerMap
o0 baseColorMap
&L coloMapWWrap
« colorM apfilter
# colorMapidth
H colorMapBorder
B scoord
E tcoord
@0 usePointalpha
& colorMapintensity

widthfold

B com.. widt.. B
B next

subtract__range 0-1-0

B inputl 4 O
H input2 complement__range 1-0-1

nEEs 1]

D val com n

globalP

0
A

globalN

a0
N

addl
PRt

O inputl sum B
B inpun2
n I

(blade_fold)

Cil‘?-p]au*fllrr |

A | ]|
v | dispr 3
0 nN dispN I3
O amount

@0 scale
K sshear

O 1shear

B polys

L objspace
.-n bump

multiply3
F==EEs
B inputl pred.. O
L input2
B input2

disp_output

Displacement

Tuesday, April 9, 13
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End Module 05

SIDE EFFECTS
SOFTWARE




