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Next Steps: Houdini Procedural Modeling

MOG: Vines - Building Vines with Attributes from L-Systems
NO ACTUAL L-SYSTEMS
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Goal of this Module

» Create Vines with Leaves
» Learn about the Polywire SOP

» Learn about the Attributes in L-Systems that the
Polywire Uses

» Learn to use the Trace SOP to make leaves

» See how we can re-purpose what we learned with pipes
to create Vines

SIDE EFFECTS
SOFTWARE
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Basic Scene Setup

Just Camera, Grid, Skylight

SIDE EFFECTS
SOFTWARE




I grid_ground

Basic Setup

» Lay down a grid 50x50 to act as a ground plane

» Drop down a Skylight and turn on - Render Light
Geometry

» Drop down a Camera Pointing to the Center of the
Ground

» Drop down a Mantra Node (PBR)
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Generating Input Curves

Making the Paths for the Vines

SIDE EFFECTS
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Creating Vine Paths

Just like our other projects we want to de-couple the input curves from our “Vine
Generator”

» This way the artist can create his own curves or import curves from another package
At the Object level drop down a Geometry Object and dive inside
Let us create a couple different types of curves

» Continued on next slide...
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Simple Curve

» Draw a couple of simple curves going up the y-axis
» To draw a 3D curve

» Turn on - Create in Context

» Start with the Construction Grid on to anchor the
first point to the Ground. I —

» Turn off Construction Grid T

» Rotate Scene View and drop down pints of curve

» Keep on rotating and dropping points
» When done switch Curve Type to NURBS

» Create a few Curves a Merge them

SIDE EFFECTS
SOF TWARE
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» In the same object drop down a sphere - make it
polygonal - frequency 3

» Append a Clip SOP - Distance 0.9
» Drop down a Line SOP
» Distance - 18
» Points 50
» Copy the Line with the Facet
» Append a Mountain SOP to distort the Vine Path

» Append a Switch and Input both types of Curves

Curve from Mountain SOP
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Making a Leaf

Remember do not use Alpha - Build the Geometry

SIDE EFFECTS
SOFTWARE
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Building a Simple Circle Leaf

» At the Object Level Dope down a Geometry Object

» Rename it Leaf and Dive Inside
» Drop down a Circle
» Type - Primitive, Orientation - XY Plane
» Radius 0.5, 0.5, Center 0.95
» Drop down a Line
» Direction O,1,0, Distance 0.5, Points - 2
» Merge Line and Curve

» Append a Transform - Rotate X 90 degrees

SIDE EFFECTS
SOFTWARE

Sunday, April 21, 13

10



Build a Leaf from a Trace SOP

» In the same Object drop down a Trace SOP

» Image Input - Let us use something from the default pic
foldermap

» Image Input - $HFS/houdini/pic/mapleleafAlpha.rat

» Append a Transform

» Rotate 90
» Translate O,0,.8

» Append a Switch
» Add the Simple Circle Leaf

» Append a Null Leaf OUT

SIDE EFFECTS
SOFTWARE




What is the Trace SOP

Traces curves from an image file.

This node reads an image file and automatically traces it, generating a set of faces
around areas exceeding a certain brightness threshold. You can control this

threshold and the resolution of the resulting faces.
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Making the Vine Trunks

Creating Vine Trunks that Twist Around Each Other

SIDE EFFECTS
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Creating the Twisting Trunk

» At the Object Level Drop down another Geometry
» Rename it Vine Generator
» Dive Inside
» Drop down a Object Merge
» Point to - ../../vine_paths/VINE_PATH_OUT
» Drop down a NURBS Circle
» Radius - 0.6, 0.6
» Order 4, Divisions 4

» Append a Sweep and use the circle to sweep the Vine paths

SIDE EFFECTS
SOFTWARE
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Creating the Twisting Trunk (cont.)

» Now like the pipes in Module O1 we need to break apart the
tubes Into separate curves to twist

» Append a Carve to the Sweep
» FirstU - O
» Second U -1

» Breakpoints Tab

» Extract 3D Isometric Curves

SIDE EFFECTS
SOFTWARE
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’ Sweep sweepl

Sweep Qutput

Paramater Spreadshaet

urve objectl

All Primitives at Each Point
.'\")lvf Fix

Fix Flipping

¥ Remove Coincident Points on

Aim at Reference Points

Use Vertex

$PCT*1.5
120

Creating the Twisting Trunk (cont.)

ow let us make the twist

Select the Sweep SOP created a few steps
ago

» Scale - $PCT (you can multiply this to get
bigger spreads)

» Twist 120

Sunday, April 21, 13
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Creating the Twisting Trunk (cont.)

LSystem lsysteml

» We are about to use the Polywire to create the
Trunks but first let us understand the attributes
by dropping down a L-System

» Drop down a L-System
» Select the Tube tab

L [e— X » Notice everything is de-highlighted

Geometry Tube Values Funcs

o » Go to the Geometry Tab and Select Point
LY Attributes

» Go back to the Tube Attribute and notice

Thickness 0.243

Thickness Scale 0.7 parameters are enabled

Vertical Increment ek

» Hover over the parameters to see names
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Edit Parameter Interface...

Edit Rendering Parameters...
Edit Deletion Script...

Edit Comments...

Revert Parameter Interface

Delete All Spare Parameters

Save Preset. ..
Save as Permanent Defaults

Delete Preset...

Revert to defaults
Revert to and restore permanent defaults

Make current values temporary defaults

LSystem Settings

e Radius $WIDTH

isions $DIV
egments $SEGS
t Scales 1.0 J/ $NSEG
¥ Prevent Joint Buckling
¥ Do Vertex Texure

1.0 - 1.0 / $NSEG

T [

‘ | polywire3

Creating the Twisting Trunk (cont.)

» Names of Importance

» rows, cols, thickinit, thickscale, vertinc

» Append a Polywire
» In the Presets for the Polywire
» Choose - L-System Settings

» Rows map to $DIV

» Columns map to $SEGS

SIDE EFFECTS
SOFTWARE
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sweep__vine_twist_and_separation Take List Parameter Spreadsheet

. obj ) fg vines

a Sweep sweep_  vine twist and separation

Cycle Type

Scale Ramp

Point No.
Position
Value
Interpolation
Scale Multiplier
Scale
Twist

Roll

All Primitives at Each Point

Angle Fix
Fix Flipping

¥ Remove Coincident Points on Path
Aim at Reference Points

Use Vertex

<
1

0.166667

Linear

0.2
ch("scale_multiplier")*chrai
60

0

Creating the Twisting Trunk (cont.)

» OK back to our Vines
» First lets add some artist controls to the Sweep
» Open - Edit Parameters
» Add a Ramp,
» hname - scale_ramp
» label - Scale Ramp
» Add a Float
» name - scale_multiplier
» label - Scale Multiplier
» Hit Accept

» In the Scale Parameter -
ch("scale_multiplier")*chramp("scale_ramp",$PCT, O)

Sunday, April 21, 13
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chramp()

float chramp (string ramp_path, float position, float component_index)
Returns the value of a ramp parameter at a specific position.
<position> must be a value from O to 1.
<component_index> is the component of the evaluated value to return. For
color ramps, it must be either O, 1, or 2. For single-valued ramps,
<component_index> must be 0.0
EXAMPLES

chramp("/obj/geo1/popneti/colori/rampcolor", 0.33, 1)

Returns second component of the evaluated ramp value at a position of 0.33
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Adding Attributes for the Polywire

After the Carve SOP append an Attribute Create
» Name - pct
» Class - Vertex
» Value - $VTX/(PNVTX-1)
Append a Attribute Promote
» Original name - pct
» Original Class - Vertex

» New Class Point

SIDE EFFECTS
SOFTWARE
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Carve Out the Area Where Leaves Will Be

» Append another Carve

» We do not want leaves growing to close to the Ground
» FirstU-0.25

» Append a Tangent OTL
» Where do | get the OTL?

» Houdini Exchange

» http://www.sidefx.com/index.php?
option=com_wrapper&ltemid=148

Ilnll SWeep  wige twist_and_sep

1] 04 1]

llll resamplel
] 04 ]|

HEERE tanopnt2

SIDE EFFECTS
SOF TWARE
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What Does the Tangent Do?

This tool lets you build tangent and radial vectors for all input curves. This op is
great for adding tangent velocities to be used in particle systems with attribute
transfer SOP or POP. The radial attribute is useful to add normals that radiate out
from a curve to birth particles from. Especially nice on circles.
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VOPSOP to Create Polywire Attributes

thickness (thickness) fit _thickness width addattrib_width

(EEnEE QU ]
thickness K val shit I B sttib new... 3

bound_thickness & E aremin E adata
sremas localv ar

B destmin

O destmax

P

thickness scale(thickness-seale

thickness_scale [ 4 l‘”tlp Y 1
bound_thickness... [ -~ _ll.
B inputl  prod... 3
B input2

B input3
n inputd

ramp1 (thickness_shape_rafp)

(41}

pCt
B ettib  suce.. E input  thick...
B input .. adeta 3 thick.,
B ptrum thick...
thick
thick..

div outputl

o]} LT W A

u attrdy new... n u P shader n
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O accel
K age
K Me
columns (columns) segs g e
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2

total segments (total_segments)

& | 1]1]] el
| : B adata
total_segments - n lecalv ar
bound_total_seq... O
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multiply2 o (1]
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& inputl  pred... O 0 adets
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n inpun3
vertical_increment(vertjgal_increment)
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Remember
to use LSystem
Preset in
Polywire

Append a Polywire and Group Vines

Resultlng

PolyWire polywire_ lsystem_Settinc ﬁ =

Group
Wire Radius
Maximum Joint Scale
mooth Point
Divisions

Segments

Segment Scales

- Twisted Vines

]
ud

$WIDTH

100

$DIV

$SEGS

1.0 / $NSEG 1.0 - 1.0 /
¥ Prevent Joint Buckling

¥ Do Vertex Texures

0

$NSEG

RSN oo

s Group vines
Create Combine Edit
¥ Group Name vines

Entity
etry Type

Merge Operation

ODperation

Number Bounding Normal
¥ Enable

Primitives

Replace Existing

create O

Group by

Edges

rdered

Pattern

SIDE EFFECTS
SOFTWARE
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Creating the Anchor Points for the Leaves

That old familiar Scatter SOP

SIDE EFFECTS
SOFTWARE




Scattering Points for Leaves

I: D polywire_ Isystem_ Settings _preset

» After the Polywire append a Scatter SOP neEn

» Try 15,000 points for now ([ |||y

» Append a Blast SOP (we do not want leaves below a
certain point)

blast_base pts_by pct Take List Parameter Spreadsheet +

. obj ) fg vines

} GrOUp B @pCt>O-456 ﬂg Blast blast base pts by pct

Group @pct>0.456

» Select - Delete Non Selected croun Tvoe  FORE

Recompute Normals
¥ Delete Non Selected
Fill Simple Holes

Delete Unused Groups
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Creating Leaf Anchor Attributes

» We want to add attributes to the anchor points to tell the
leaves what size they are

] £

ﬂd' VOP SOP vopsop__leaf_anchor_attr: Q =1

(1 )
Controls Settings
Instance Scale 1

» We want the artist to control

¥ Add Leaf Size Ramp

Leaf Size Ramp

» The general ramp up of leaf size along the vines e
backbone (pct)

s . oint No. 2
» A Minimum Random Size o
Value 1
} A MaX|mum RandOm SIZG Interpolation Linear
. ¥ Add Random Size
» A See Value for the Random Function Min Random Size 0.9

Max Random Size 1B |

» Append a VOPSOP B
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Creating Leaf Anchor Attributes

outputl

instance scale(instance scale) _III

globall g ———— multiply _ size pscale D
| R —— (o o

Pw 3
'O
accel u
age n
life I3
pstate u
id 3
ptnum [
cd 3

n 3

net [
Time n
Frame n

Timelne n

ranriﬂml

os rand u

__pct
n attrib success

3 input_. adata n
u ptnum

__random_size

n val shift n
n sremin
u sremax

@d destmin
')-u destmax

rampl(leaf size ramp)

B input  leaf_si...
leaf_si...
leaf_si
leatf_si... L2
leaf_si... n

instance_scale |3
_l.. bound_instance_sc... [[J
rQ

do ramp_size

condrt result n
n inputl
n input2

n inputl
n input2
n input3
n input4

product n

n attrib
3 adata
n locale ar

newa..

O accel
& age
0 lfe
n pstate
v BT

& cd

[ ]

Sunday, April 21, 13

29



Creating Leaf Anchor Attributes (cont.)

| polywire Isystem_ Settings _preset

B scatter1
» Append a Null SOP to the VOPSOP

Illl blast_base pts by pct

» Name - Leaf Anchors

» Append another Null SOP
BRI o vchor » Name - LEAF_ANCHORS_OUT

llll vopsop__leaf_anchor_attributes

O OUT _leaf_anchors
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Edit Parameter Interface

Existing Parameters

¥ 5 parameters selected for editing.

Show Invisible Parameters
=-® root

™ Transform

W Material

™ Render

W Misc

2 'mm Instance
= |nstance Object (instancepath)
g” Instance Transform (instancexform)
= Point Instancing (ptinstance)

Point Motion Blur (ptmotionblur)

Using Instances to Create Leaves

» At the Object Level Create a Geometry Object
» Name - leave_generator
» Select - Edit Parameter Interface
» Select the "For Rendering” Tab
» In the Filter field type “Instance”

» Under mantra Move the entire Instance Folder over

» Click Accept

SIDE EFFECTS
SOFTWARE
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Using Instances to Create Leaves (cont.)

» Dive Inside the leave_generator
» Delete the File SOP
» Drop down an Object Merge

» Object - ../../vine_generator/
LEAF_ANCHORS_OUT

leaf generator Take List Parameter Spreadsheet U Re I I I e I I I b e r

. ODbj

E—— for Fast point » Back at the leaf_generator object

Transform Material Render Misc Instance

instancing you » Instance Object - /obj/leaf

¥ Instance Transform

Point Instancing Fast point instancing need an absolute . I . .
» Point Instancing - Fast Point Instancing

Path

SIDE EFFECTS
SOFTWARE
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Take List

~. 0Dbj

f‘ Geometry leaf

Transform Materia

Phanton

Renderable

Shading Sampling Dicing Geometry

Categories
Reflection Mask
Refraction Mask
Light Mask
/olume Filter Box Filter

Volume Filter Width 1

Setting up the Leaf Object for Instancing

» Turn on the Visibility Flag
» In the Render Tab turn off Renderable

SIDE EFFECTS
SOFTWARE
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Drawing a Curve on an Object

Wrapping Vines around an Object

SIDE EFFECTS
SOFTWARE




» Drop down a Tube at the Object Level
» Tube Tab

» Primitive type - Polygon

» Height - 15

» Radius - 1,3
» Detall Tab

» Rows - 40

» Columns - 40

Setup

tubel Take List

Parameter Spreadsheet

. obj ) T tube objectl
Jump Back Alt+LeftArrow

i Tube tubel

Tube Detail
Primitive Type
Connectivity
Orientation
Center
Radius

Height

Polygon
Quadrilaterals
Y axis

0

1
15

.....

Bedddad

.....

vvvv

.....

,,,,,,,,

iz Tube tubel

Tube Detail
Rows 40

Columns 40

Take List Parameter Spreadsheet

. obj } Fg tube_objectl

End Caps

SIDE EFFECTS

SOF TWARE
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» Inside the Tube Object
» Drop down a Curve SOP
» Select the Visibility Flag
» On the Tube SOP Control Click on the Template Flag

» Control Clicking makes the Template Selectable

» Back up at the Object Level
» Select Primitive Snapping

» Right Click on Primitive Snapping
» Turn Off other Objects

Drawing the Curve

Apply to
& Templates

| | Other Objects

Properties

W Depth Snapping

| Orient on Snap

Primitive Snapping Options...

SIDE EFFECTS
SOF TWARE
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» Turn off the Construction Plane

» Draw curve on Tube

» In the Curve SOP
» Primitive Type - NURBS
» Method - Breakpoints

Drawing the Curve (cont).

Take List

Parameter Spreadsheet

%. obj ) Tg tube_objectl

urvel

Primitive Type

Method

NURBS

Breakpoints

-0.604057, -1. 2966, 2. 08271 0.353928, -0.528427,2.03776 1.3602

Curve Properties Fitting Properties

Close
Reverse

Normaliz

e Basis
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End Module 06
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